Marketplace Perfomance Booster ( Varnish ) Esi Render Problem


#1

We are using unitheme 2 with light 2 layout.
Marketplace performance booster addon wrong rendering esi blocks.
i try explain whats wrong with code parts and images.

varnish_problem

esi disabled block source codes.
--------------------------------------------------------------
<div class="ut2-top-my-account ">
    <div class="ty-dropdown-box" id="account_info_2998"></div>
</div>
<div class="ut2-top-cart-content ">
    <div class="ty-dropdown-box" id="cart_status_2999"></div>
</div>

Esi enabled block source codes ( you can see the its rendering blocks inside by inside
--------------------------------------------------------------------------------------
<esi:include
        src="http://www.domain.com/esi.php?block_id=292&amp;snapping_id=2998&amp;lang_code=tr&amp;requested_uri=%2xxxxxxxxxxxxxxx">
    <esi:remove>
        <div class="ut2-top-my-account ">
            <div class="ty-dropdown-box" id="account_info_2998"></div>
        </div>
    </esi:remove>
    <esi:include
            src="http://www.domain.com/esi.php?block_id=293&amp;snapping_id=2999&amp;lang_code=en&amp;requested_uri=%2xxxxxxxxx">
        <esi:remove>
            <div class="ut2-top-cart-content "></div>
        </esi:remove>
    </esi:include>
</esi:include>

its mut be render following. am i wrong ?
-------------------------------------------
<esi:include
        src="http://www.domain.com/esi.php?block_id=292&amp;snapping_id=2998&amp;lang_code=en&amp;requested_uri=%2xxxxxxxxxxxxxxx">
    <esi:remove>
        <div class="ut2-top-my-account ">
            <div class="ty-dropdown-box" id="account_info_2998"></div>
        </div>
    </esi:remove>
</esi:include>

<esi:include
        src="http://www.domain.com/esi.php?block_id=293&amp;snapping_id=2999&amp;lang_code=en&amp;requested_uri=%2xxxxxxxxx">
    <esi:remove>
        <div class="ut2-top-cart-content "></div>
    </esi:remove>
</esi:include>

#2

Здравствуйте. К сожалению, мы не можем помочь с данной проблемой на форуме, а только через Help Desk. Чтобы изучить и решить эту проблему, нужен доступ к серверу.

P.S
Важный момент: общение на форуме ведётся только на русском языке. Для общения на английском языке есть отдельный форум: https://forum.cs-cart.com/. В Help Desk мы можем ответить как на русском, так и на английском.


#3

Но до активации блоков esi все выглядит нормально. как это может быть проблема третьей стороны?