Не Запускается Копия Магазина На Локалке

Добрый день, вопрос наверное глупый, но все же задам. Сделал бекап сайта, стоит Open Server, создал новую БД импортировал в нее БД магазина, закинул папку сайта в OpenServer/Domains, в config.local.php поправил подключение к базе. Пытаюсь запустить, оно автоматически перекидывает на сайт в сети, я так понимаю что это из-за того, что в админке URL Витрины - стоит URL сайта, как его можно изменить не заходя в админку, т.к. на локалке при заходе в админку пишет Страница не найдена.

Поменял URL в базе данных в таблице cscart_companies на site, сайт заработал. Теперь когда захожу в админку site/admin.php пишет Страница site не работает

На следующей странице есть инструкция по переносу установки:

http://www.cs-cart.ru/docs/4.3.x/install/fast/index.html

Убедитесь, что были выполнены все шаги

Да, эти шаги выполнены и проверены. Сайт работает, а при входе в админку выдает:

Страница site не работает
Сайт site пока не может обработать этот запрос.
Не пойму в чем дело.

Да, эти шаги выполнены и проверены. Сайт работает, а при входе в админку выдает:

Страница site не работает
Сайт site пока не может обработать этот запрос.
Не пойму в чем дело.

Попробуйте следующее:

1. Проверьте журнал ошибок. Ошибка должна была залогироваться

2. Добавьте строки:

    define('DEVELOPMENT', true);
    error_reporting(E_ALL);
    ini_set('display_errors', 'On');

в конец файла config.local.php и попробуйте открыть панель администрирования еще раз.

3. Проверьте права на скрипт админки

Вот что пишет в логах OpenServer:
PHP Fatal error: Uncaught exception 'InvalidArgumentException' with message 'Identifier "view" is not defined.' in C:\OpenServer\domains\back\app\lib\vendor\pimple\pimple\src\Pimple\Container.php:95
Stack trace:
#0 C:\OpenServer\domains\back\app\functions\fn.common.php(2670): Pimple\Container->offsetGet('view')
#1 C:\OpenServer\domains\back\app\functions\fn.common.php(555): fn_get_current_mode()
#2 C:\OpenServer\domains\back\app\functions\fn.init.php(786): fn_process_cache_notifications('fgber_zbqr_jvyy...')
#3 [internal function]: fn_check_cache(Array)
#4 C:\OpenServer\domains\back\app\functions\fn.init.php(960): call_user_func_array('fn_check_cache', Array)
#5 C:\OpenServer\domains\back\init.php(138): fn_init(Array)
#6 C:\OpenServer\domains\back\cp.php(25): require('C:\\OpenServer\\d...')
#7 {main}
thrown in C:\OpenServer\domains\back\app\lib\vendor\pimple\pimple\src\Pimple\Container.php on line 95

Попробуйте следующее:

1. Проверьте журнал ошибок. Ошибка должна была залогироваться

2. Добавьте строки:

    define('DEVELOPMENT', true);
    error_reporting(E_ALL);
    ini_set('display_errors', 'On');

в конец файла config.local.php и попробуйте открыть панель администрирования еще раз.

3. Проверьте права на скрипт админки

Изменений никаких не произошло, ошибок не показало, пишет:

Ошибка сервера
Возникла ошибка сайта при загрузке http://back/cp.php. Возможно, сайт закрыт на техническое обслуживание или неверно сконфигурирован.

Вот что пишет в логах OpenServer:
PHP Fatal error: Uncaught exception 'InvalidArgumentException' with message 'Identifier "view" is not defined.' in C:\OpenServer\domains\back\app\lib\vendor\pimple\pimple\src\Pimple\Container.php:95
Stack trace:
#0 C:\OpenServer\domains\back\app\functions\fn.common.php(2670): Pimple\Container->offsetGet('view')
#1 C:\OpenServer\domains\back\app\functions\fn.common.php(555): fn_get_current_mode()
#2 C:\OpenServer\domains\back\app\functions\fn.init.php(786): fn_process_cache_notifications('fgber_zbqr_jvyy...')
#3 [internal function]: fn_check_cache(Array)
#4 C:\OpenServer\domains\back\app\functions\fn.init.php(960): call_user_func_array('fn_check_cache', Array)
#5 C:\OpenServer\domains\back\init.php(138): fn_init(Array)
#6 C:\OpenServer\domains\back\cp.php(25): require('C:\\OpenServer\\d...')
#7 {main}
thrown in C:\OpenServer\domains\back\app\lib\vendor\pimple\pimple\src\Pimple\Container.php on line 95

Вот и причина. Проверьте файлы:

app/schemas/literal_converter/utf8.php
app/Tygh/Helpdesk.php

Файлы должны быть бинарно идентичны стандартным файлам CS-Cart (сраваниются хэши). Оригинальные файлы можно взять из установочного пакета CS-Cart той же версии что и у вас.

Спасибо, попробую и отпишусь. Хотя странно, эти файлы никто не трогал, CS-Cart покупали еще была версия 4.3.3, потом обновлялись до 4.3.4, сейчас версия 4.3.5, хотел протестировать обновление до 4.3.6 на локалке и появилась такая проблема.

Файлы заменил, все заработало. Заменил так же их и на сервере. Хотя на сайте в админку заходило без проблем, не получалось зайти только на локалке.

Сделал после замены этих файлов на сервере новый бэкап, запустил на локалке проблема опять та же, теперь получается что каждый раз при заливке сайта на локалку нужно заменять эти файлы, чтоб он работал. Почему появилась такая проблема?

Сделал после замены этих файлов на сервере новый бэкап, запустил на локалке проблема опять та же, теперь получается что каждый раз при заливке сайта на локалку нужно заменять эти файлы, чтоб он работал. Почему появилась такая проблема?

Попробуйте сравнить файлы оригинала и файл, который получается после бекапа. Возможно при переносе файлы как-то модифицируются.