Вышел Cs-Cart 4.7.2


#1



Привет!

Мы рады сообщить, что выпустили CS-Cart 4.7.2. Хотя в патчевых релизах мы в основном исправляем обнаруженные ошибки, версия 4.7.2 должна многих заинтересовать, и вот почему:

  • Поддержка PHP 7.2 и ImageMagick 7.
  • Улучшения вариаций товаров. Добавлена возможность создавать вариации по-одной (без перезаписи существующих вариаций товара), импортировать новые вариации, а также экспортировать вариации в Яндекс.Маркет и Google Merchant Center (через модули “YML экспорт” и “Прайс-лист для Google Base” соответственно).
  • Исправлен баг со ссылками на вариации товаров. Раньше на витрине использовались SEO-ссылки на вариации, хотя они не должны появляться, и их нельзя редактировать. Теперь на витрине отображаются правильные ссылки на вариации.
  • Улучшение отображения страниц товаров с обязательными опциями. Теперь покупатель увидит количество товара в наличии только после того, как выберет варианты для всех обязательных опций.
  • Исправлен ряд ошибок: проблемы при обмене данными по CommerceML, проблемы на странице оформления заказа после смены адреса при использовании СДЭК и Pickpoint, проблема с оплатой заказа через Яндекс.Кассу в небазовой валюте, и другие.
Подробнее об изменениях и улучшениях в версии 4.7.2 читайте в нашем блоге; полный список исправлений и улучшений есть в журнале изменений. Обновление до CS-Cart 4.7.2 уже доступно. Как всегда, мы отдаём обновление партиями, поэтому если вы не видите его в Центре обновлений, попробуйте обновиться позже.

P.S. Мы выпустили 4.7.2 Service Pack 1, который исправляет проблемы с работой мультивитринности и некоторых модулей. Также был выпущен SP2, исправляющий проблему с переводами настроек в SP1. Подробности читайте в журнале изменений SP.

#2

Сорри, разобрался.

upd

Проблема так и осталась, не работает поиск, если если искать товар по коду товара CODE а в магазине есть товары с кодами CODE1 и CODE2 то вместо выдачи списка из друх товаров вылетает красный баннер сервис недоступен. Обновляю магазин - ошибка, откатываю на предыдущую версию - работает.


#3

Сорри, разобрался.

upd

Проблема так и осталась, не работает поиск, если если искать товар по коду товара CODE а в магазине есть товары с кодами CODE1 и CODE2 то вместо выдачи списка из друх товаров вылетает красный баннер сервис недоступен. Обновляю магазин - ошибка, откатываю на предыдущую версию - работает.

Посмотрите сообщение об ошибке в исходном коде страницы Service Unavailable (в самом конце) или напишите нам через Help desk, чтобы мы смогли изучить проблему в вашей установке.

Нам не удалось воспроизвести эту проблему в чистой 4.7.2.


#4

Не могу понять, как теперь генерировать вариации.

В опциях кнопка "Сгенерировать вариации" пропала, в вариациях есть кнопка "Добавить вариации", но по ней появляется пустой список, который можно только закрыть.


#5

После обновления в настройках пункты на английском языке, а также и внутреннее содержимое.

http://prntscr.com/ii3t0p


#6

Частично после обновления пропал русский язык.

http://joxi.ru/v29aZ64HGaQ602


#7

Подтверждаю, в настройках слетел русский язык.

https://prnt.sc/ii77q0


#8

После обновления в настройках пункты на английском языке, а также и внутреннее содержимое.

http://prntscr.com/ii3t0p

Частично после обновления пропал русский язык.

http://joxi.ru/v29aZ64HGaQ602

Подтверждаю, в настройках слетел русский язык.

https://prnt.sc/ii77q0

Проблема в SP1. Мы предоставим решение в ближайшее время


#9

Где то написано как работать по новому с вариациями?

У меня две опции

http://joxi.ru/DmBypOnCNL6jDr

пытаюсь их с вариировать, выдает следующее.

http://joxi.ru/Q2KlENVU9lg0jA


#10

Где то написано как работать по новому с вариациями?
У меня две опции
http://joxi.ru/DmBypOnCNL6jDr
пытаюсь их с вариировать, выдает следующее.
http://joxi.ru/Q2KlENVU9lg0jA


Галочка "Расчет кол-ва товаров в наличии" у опций стоит? У меня такая проблема возникала, только если галочка не была проставлена у тех опций, из которых надо вариации генерировать.

#11

Да, сработало. Спасибо.


#12

А поддержка ImageMagick 7 - это чтоб его использовать нужно на самом сервере его устанавливать?


#13

Да, ImageMagick должен быть установлен на сервере