Обновление версии PHP и откат к старой версии


#1

При обновлении версии PHP c 7.0.33 (alt) на 7.1.33 (alt) / 7.2.34 (alt) / 7.3.28 (alt)

Появились вот такие ошибки, что странно откат к старой версии PHP не помогает, ошибки остаются

Notice: Undefined index: q_p_id in /var/www/www-root/data/www/имя сайта/app/functions/fn.log.php on line 314

на странице заказа, если у клиента больше одного заказа
https://имя сайта/admin.php?dispatch=orders.details&order_id=55994

Notice: Undefined offset: 1 in /var/www/www-root/data/www/имя сайта/app/Tygh/Navigation/LastView/ACommon.php on line 352

Notice: Undefined index: total_items in /var/www/www-root/data/www/имя сайта/app/addons/rf_order_history/controllers/backend/orders.post.php on line 45


#2

кстати системные версии указаны только для 4.3.x версий
https://www.cs-cart.ru/docs/4.3.x/install/requirements/

для 4.9.х нужно гадать о совместимости PHP версий и версий карта?


#3

Вот тут указано

https://www.cs-cart.ru/docs/latest/install/system_requirements.html?


#4

да, но если пойти по моей ссылки и оттуда выбрать другую версию карта, на страницу системных требований для это версии вы не попадете, там структура переделана и найти как попасть на страницу системных требований для версий старше 4.3.x не так то просто


#5

4.6.x
4.7.x
4.8.x
4.9.x
4.10.x
4.11.x
4.12.x
4.13.x


#6

За это спасибо наверное скажет ведущий документацию по карту )
Мне бы кто подсказал, как убрать ошибки которые возникли


#7

Ошибки на странице заказа похоже связаны с модулем история заказов клиента от retailfactory(попробуйте отключить и посмотреть пропадут ли ошибки. А далее скорее всего нужно будет обновить модуль или создать тикет разработчикам). Ошибка с логом(Undefined index: q_p_id) вообще не понятно, такого параметра в карте нет(смотрел 4,9 и последнюю), так что похоже тоже какой то модуль.


#8

спасибо, всем разработчикам модулей тоже создал тикеты.
Но говорят проблемы и в ядре есть