Ошибка Базы - Пытается Писать Null


#1

Простите, люди добрые, может кто подскажет, что делать, куда бежать?

Вдруг в журнале вижу такую штуку:

База данных (Ошибка)
Ошибка: Column 'variant_id' cannot be null (1048)
Запрос: REPLACE INTO cscart_product_features_values (`product_id`, `feature_id`, `variant_id`, `lang_code`) VALUES (544, 67, NULL, 'ru')
Отслеживание››

index.php (fn_dispatch): 25
app/functions/fn.control.php (fn_run_controller): 460
app/functions/fn.control.php (include): 702
app/controllers/frontend/checkout.php (fn_checkout_place_order): 380
app/functions/fn.cart.php (fn_place_order): 8601
app/functions/fn.cart.php (fn_change_order_status): 1377
app/functions/fn.cart.php (fn_update_product_amount): 2311
app/functions/fn.cart.php (fn_set_hook): 882
app/functions/fn.control.php (fn_ecl_filter_by_options_update_product_amount): 152
app/addons/ecl_filter_by_options/func.php (fn_ecl_filter_by_options_update_product_feature_values): 82
app/addons/ecl_filter_by_options/func.php (db_query): 351
app/functions/fn.database.php (query): 133
app/Tygh/Database/Connection.php (throwError): 488

Полез в журнал потому, что вдруг (ничего не делал, не включал, не выключал, на ровном месте) на последнем шаге оформления заказа при выборе оплаты через выставление счета, после нажатия кнопки «Оформить заказ» выбрасывает на экран «Закрыто».

При попытке оплаты картой перебрасывает на платежный интерфейс, дальше не проверял.

Где искать?


#2

В конце концов по логу все сводится к аддону ecl_filter_by_options и из fn_ecl_filter_by_options_update_product_feature_values в app/addons/ecl_filter_by_options/func.php идет обращение к базе на строке 351

скорее всего надо обратиться к eCom labs - их аддон?


#3

В конце концов по логу все сводится к аддону ecl_filter_by_options и из fn_ecl_filter_by_options_update_product_feature_values в app/addons/ecl_filter_by_options/func.php идет обращение к базе на строке 351

скорее всего надо обратиться к eCom labs - их аддон?

Да, их. Больше года работает. В выходные (в понедельник) я делал обновление на 4.7.1 SP 2, после этого все работало, заказы нормально люди оформляли и вдруг.... Попробую обратиться.

:-(


#4

Да, их. Больше года работает. В выходные (в понедельник) я делал обновление на 4.7.1 SP 2, после этого все работало, заказы нормально люди оформляли и вдруг.... Попробую обратиться.

:-(

Напишите нам, изучим